Take the 2-minute tour ×
Musical Practice & Performance Stack Exchange is a question and answer site for musicians, students, and enthusiasts. It's 100% free, no registration required.

I am looking to try and record some music using Guitar rig + reaper. However I am having an issue with sound only playing through the right on my headphones. When I record a piece, and play it back, same problem, only comes through the one headphone

When I use guitar Rig on its own, I have no problem, it sounds great, however when I integrate guitar rig into reaper, and turn on record monitoring, I only hear the sound through the right headphone. Has anyone else had this issue?

This only happens with the guitar rig integration. I have tried the other built in reaper sound effects and they all work fine.

I have tried looking through the audio options but nothing I have tried so far has fixed this. Any help would be much appreciated.

Edit:

Also while I am at it, does anyone know how to solve the latency issue? Is it possible to reduce the latency so that it is barely noticeable? I have a fairly powerful machine, 8 Gig ram, I7 processor, but I am getting an annoying delay when I turn on monitoring mode?

Any suggestions on good methods to fix latency issues?

Edit 2: My temporary fix to the latency issue, is to load up guitar rig outside of reaper, and turn off recording mode in reaper..

share|improve this question

1 Answer 1

up vote 1 down vote accepted

about your first problem ::: I think it should be an output sound setting problem in guitar rig , if you are creating an stereo track in Reaper try to create a mono audio track there and your problem should be fixed...

about second problem ::: your CPU and RAM power is a part of your work , another part is ::: which sound card or interface you are using? professional sound cards have a latency or buffer size settings for their inputs... and some sound cards have direct inputs (ignore latency feature)... but for now if you are using a typical sound hardware and don't have buffer size option in audio interface settings in Reaper , you should download ASIO4ALL and change your audio device in Reaper to ASIO4ALL and control your buffer size from there (lower size = lower latency = higher CPU and memory usage)... for recording it's good to have a buffer size about 256 or 512 but for editing , mixing , mastering probably you need more buffer sizes... you can download ASIO4ALL from here : http://www.asio4all.com/

share|improve this answer
    
I managed to fix the problem, it was a mistake in my audio settings, I had not set the output properly, I have asio4all. I have lowered my buffer size as you suggested, and the latency problem seems to have gone away now. Cheers –  AdamM Feb 26 at 9:17
    
good for you ;) –  Mohammad Rafigh Feb 27 at 8:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.