Take the 2-minute tour ×
Music: Practice & Theory Stack Exchange is a question and answer site for musicians, students, and enthusiasts. It's 100% free, no registration required.

In music sometimes a line is repeated with the repeat bar ||: :||. I'm using Sibelius and it doesn't seem to understand the repeat bar when it creates midi's with lyrics. It jumbles the text of the lyrics mixing the first and second line. Could someone tell me how to split the lyric lines and do proper repeats automatically?

This is what it looks like now:

enter image description here

share|improve this question
1  
You should post this question at the Sibelius help forum. sibelius.com/cgi-bin/helpcenter/chat/chat.pl?groupid=3 –  Wheat Williams May 2 at 15:23
    
@WheatWilliams that's great that you suggest the Sibelius help forum for the OP. I have to say though, as a daily Sibelius user, I find their site a bit difficult to navigate; I much prefer the way this site works, and the fact that users are music-buffs, not just Sibelius users. I just wanted to check, Sibelius questions/answers are on topic, right…? –  Bob Broadley May 2 at 19:48
    
@caseyr547 I assume you know about how to put repeat bars in a Sibelius file and how to create line 1 and line 2 lyrics. I have just replicated the problem you are having, by saving as MIDI with lyrics from Sibelius (didn't know you could do that, so I've learnt something today!) and then reopening in Sibelius. For me, the lyrics for the first repeat come out fine, but then I get both sets of lyrics for the second repeat. Anyway, I'm trying to find a solution... –  Bob Broadley May 2 at 19:53
1  
Yes, Sibelius questions are on-topic here. And yes, the Sibelius help forum is very hard to navigate. But a lot of Sibelius experts read and post on the Sibelius help forum frequently. It's a good place to go for Sibelius users. –  Wheat Williams May 2 at 20:01

1 Answer 1

up vote 2 down vote accepted

Okay, I scoured the web trying to find answers, but had no luck. After a bit of lateral thinking I have found a solution for you…

Select all of your Line 1 Lyrics (on Mac I click on the first syllable of the line and press shift-cmd-A). Then open the Inspector (right click on the lyric text and select Inspector). Then uncheck the "2" box under "Play on pass:" (which is itself under "Playback"). To be absolutely safe, you could uncheck all except the "1" box, but this seems like overkill.

enter image description here

This seemed to work fine when I Exported as MIDI and then reopened in Sibelius. It's worth noting that you can also Export as MusicXML files, depending upon which program you want to open the file in. And, of course, an absolutely safe way to get around these problems is to simply enter music with no repeats, but instead written out in full!

Thanks to @Wheat Williams for Sibelius forum advice.

share|improve this answer
    
ok but uh it didnt have that option and i dont know what to do this is what it looks like uploading.com/e13df17d/the-lord-our-God-opt and this is what it makes in my copy of sib uploading.com/493398m8/thelordourgod-mid –  caseyr547 May 2 at 20:34
    
Okay, I just opened your file (what is an .opt file BTW?!) Both your lines of lyrics are inputed using "Lyrics line 1". The lower line of lyrics (for the repeat) should use "Lyrics line 2". What option couldn't you find? The Inspector…? –  Bob Broadley May 2 at 20:39
    
opt is photoscore a another program from the people who make sib –  caseyr547 May 2 at 20:49
    
Of course… Anyway, which option couldn't you find? –  Bob Broadley May 2 at 20:50
    
it doesnt show any option to change lyrics line –  caseyr547 May 2 at 20:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.