Take the 2-minute tour ×
Music: Practice & Theory Stack Exchange is a question and answer site for musicians, students, and enthusiasts. It's 100% free, no registration required.

I'm using Logic Pro (I have Snow Leopard) and I have a Korg R3 and a VB-99 as music instruments... I use usb connection on both and I would like to have suggestions and ideas to get rid of the latency when recording. Using my actual hardware with software tweakings would be lovely but also suggestions about buying new hardware that would solve the problems (cheap, if possible :) ) is appreciated.

share|improve this question
    
How bad is the latency? –  yossarian Oct 5 '11 at 13:30
    
I'd say something like 0.1, 0.2 seconds... –  Pitto Oct 9 '11 at 14:42
    
What hardware are you using, I have a Quad Core Mac and don't see any latency with my Roland GR-30 regardless of which software instrument I am using? –  Jarrod Roberson Oct 10 '11 at 19:35
    
I have an Hackintosh (I5 quad core, 4gb ram, ssd) and it's performing great. Something is probably related to the fact that I'm connecting my Korg and Roland using USB. I'd just like to see if there are any software or hardware tricks to get over the problem :) –  Pitto Oct 11 '11 at 11:13

7 Answers 7

What I do for critical recordings: I simply don't use virtual instruments running on the computer, but split the MIDI signal, route only one path to the interface and the other to a cheap general-MIDI sound module. This sounds horrible, but has neglectable latency so I can well use it for monitoring and get an as-clean-as-possible MIDI track. Once that's recorded, latency doesn't matter anymore and I can switch to the better-sounding virtual instruments.

Where the sound module offers insufficient quality even for monitoring, I try step by step reducing the latency. I usually go down to 48 samples, though with that I already get stability problems when running processor-intensive plug-ins. It's a bit of trial-and-error.

share|improve this answer
1  
+1 Cheap, reliable solution, I do exactly the same with 3.5mm jacks when recording from an ancient non-midi keyboard. –  ACarter Dec 22 '12 at 19:56

If you're on Windows, it's almost certainly not a hardware problem. The situation is caused by the audio output going through the Windows mixer before going to the sound card. That adds a significant delay.

Look in your audio application settings for ASIO or WASAPI output. If ASIO, you need to download ASIO4ALL. This will let your program bypass the Windows audio subsystem and talk directly to the sound card.

Using ASIO or WASAPI, the latency with my onboard sound is good enough that I can play on my MIDI keyboard without a noticeable delay.

share|improve this answer
    
Logic Pro is a Mac application. –  NReilingh Oct 8 '11 at 14:13
    
I am on Mac: sorry if I wasn't very accurate –  Pitto Oct 9 '11 at 14:43
    
I would think the ( Snow Leopard ) would give it away! –  Jarrod Roberson Oct 10 '11 at 19:33
    
@Pitto Sorry, didn't see that for some reason :P –  Rei Miyasaka Oct 10 '11 at 21:54
    
Also it sounds as if you are talking about PCM sound. This question is about MIDI. –  finnw Oct 11 '11 at 17:53

A core element of latency is often dependent on the audio interface to your PC - the sound card on your motherboard probably won't be up to the job of even semi-pro audio.

We use M-Audio for most of our stuff that goes through a PC, as we can guarantee very low latency (all the bottleneck pieces are moved off onto hardware to ensure this)

(I'm not affiliated with M-Audio, but their kit works well for us as we are heavily dependent on computers in our rhythm section.)

share|improve this answer

Find in your DAW settings where you can set the buffer size, lowering this to 256 or 512 can get you down to the 20-30 ms range where there is less noticable latency. Otherwise you can fiddle with 'Software Monitoring', and I think there is a way to make it pass directly through.

share|improve this answer
2  
This would affect digital audio, but I don't think it has anything to do with MIDI latency. –  slim Oct 7 '11 at 9:28
up vote 1 down vote accepted

Logic has a very simple solution for this: The low latency button (looks like a car tachimeter in main toolbar). Press it and then record.

:)

share|improve this answer

USB is great in that it provides inexpensive connectivity options, but there is a good reason that more expensive standards exist. This is one of them. I'd suggest trying to get your hands on a good Firewire audio interface, such as from Avid's M-Audio line.

share|improve this answer

I have a decent pc and I bought a new icon ikeyboard but it had horrible latency even after installing its driver .After reading a few blogs all I did was just installed the ASIO4ALL and that was it , did not even had to do any configurations, my pc recognised it itself and the latency is gone.I use sonar and it worked for me , I hope it does for you too. Good luck

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.