6

I am writing tabs from TuxGuitar and then export it to lilypond (Because I find it easier to do it in TuxGuitar). Here before exporting it to lilypond everything seems nice: enter image description here

But when I export and engrave it with lilypond it seems like this: enter image description here As it is seen note positions are not correct. How can I fix this? Is it about TuxGuitar or lilypond? Or what kind of program should I use to write tabs and export it to lilypond easier?

6

It looks like that TuxGuitar fails to set the proper clef.

Just find the music in the lilypond file and put \clef "G_8" in front of it. That will do the trick.


Explanation: As Tom_C correctly points out, guitar is written in treble clef but one octave higher than it actually sounds. TuxGuitar apparently just sets a treble clef (or no clef at all, which amounts to the same). The systemic way to handle that is to use a treble clef with a small 8 under it (which says that everything has in fact to be played one octave lower). That's the clef that Lilypond knows under the name of G_8 (or treble_8).

Setting the proper clef will also make sure that Lilypond will both "know internally" the correct notes and typeset them correctly, too. You could just transpose everything an octave higher; however, if you for instance played the MIDI generated by Lilypond, it would also sound an octave higher than it should.

| improve this answer | |
  • 1
    Neat! I was sure that someone with good LP skills would have a nice way to do that! – Tom_C Jul 2 at 12:40
2

This is probably linked to : why is guitar music written one octave higher?

An easy fix would be to transpose everything 12 half tones higher but not sure if it easier in Tux or Lilypond...

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.