4

I'd like to switch the record arm of specific tracks in Reaper using a Behringer FCB 1010, which is a MIDI footswitch.

As an example, let's say I have 4 tracks in Reaper:
3 for guitar (same input, but different FX);
1 for piano.

I'd like to arm only one guitar track at a time. How could I use the footswitch so that pedal 1 would only arm the first guitar track and disarm the other two? Likewise, when I press pedal 2 on the footswitch, then the second guitar track should be armed, and the other two guitar tracks disarmed. But it is important for me that the piano track stays armed all the time. I think that would be a rather usual usage of controlling guitar effects via MIDI in live situations with multiple players.

I tried creating custom actions and link them to the pedals:
Pedal 1: "Toggle record arm for last touched track" + "Toggle record arm for track 01"
Pedal 2: "Toggle record arm for last touched track" + "Toggle record arm for track 02"
Pedal 3: "Toggle record arm for last touched track" + "Toggle record arm for track 03"

In this case, pedal 1 does not seem to do anything, and pedals 2 and 3 change the arming of multiple channels.

Are there options I'm missing that could help me solve that? Any help is appreciated!

  • "Toggle record arm for last touched track" + "Toggle record arm for track 01" : at the first glance these two seem to be redundant, why not only the second one? (Note that I do not use Reaper). Note also (may prove useful, or not) that the FCB is not sending momentary (nothing happens when you release): if you set it to send 127 on CC5, it will do each time you press, but will not return to zero. (This caused me troubles…) – Tom Sep 14 at 20:20
2

The two "toggle" commands in series relies on a specific state for the toggles to work as intended. However, according to "https://wiki.cockos.com/wiki/index.php/Action_List_Reference", there is an action called "Track: Unarm all tracks for recording (40491)"

This would allow you to know for certain the armed state of all tracks.

If you use this command instead of the "last touched" command, and then send a "toggle" command to a specific track, the arming state will always be "true."

Try: "Unarm all + toggle track 1"

| improve this answer | |
  • Works perfectly! It doesn't seem to be that great for live situations however; I noticed that the FX for each track takes too long to switch (around half a second). I didn't yet test whether that's the case for all FX or only the one I use (EZ Mix). – Nico Autia Sep 23 at 6:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.