1

I've used TuxGuitar for a while now and it's good enough for a free product. However, I recently downloaded the most recent version and noticed that when I play what I've typed into the TAB the rhythm is ridiculously off. Simply put, the s/w does not play what I wrote with a nice steady uniform meter. It almost sounds like there's a bug in the programing. It I thought it was a person performing I'd give them an F. It's really that bad. Steady 16th notes seem to be playing as if they are galloping, with occasional n-tuples played fast then a pause.

I have heard about a function in Band in a Box called "humanize" that is supposed to introduce random deviations in tempo to mimic what someone thinks a human does when they play. Could that be at play in TuxGuitar? And if it is can it be turned off? I did not notice this in older editions but to be fair I usually use MuseScore, which plays scores correctly, and then use Tux for TAB in rare cases where I don't want to forget intricate fingering patterns I've worked out.

6
  • Which operating system are you running it on? – ojs Dec 22 '20 at 22:35
  • Windows 10 ........ – ggcg Dec 22 '20 at 23:31
  • @ojs, are you familiar with TuxGuitar? Could it be the OS causing a timing issue? I don't get with MuseScore. – ggcg Dec 23 '20 at 1:16
  • 1
    I'm not familiar with TuxGuitar, but some time ago I fixed a similar bug in a different app. The root cause was that the audio callback timing was really random on some systems, and the app was expecting them to be at steady intervals. Not sure if it's more because of operating system or sound card. So... it's probably a bug in TuxGuitar that shows up only on some systems. Good luck reporting it and getting something else than "works for me" as an answer. – ojs Dec 23 '20 at 10:48
  • Your description of TuxGuitar playback actually reminds me of Musescore playback...on their website with the Synthesizer audio source. It's possible that TuxGuitar music loading is a similarly intensive process with common loading and buffering bottlenecks. – Dekkadeci Dec 23 '20 at 13:24
2

Caveat: I have not used TuxGuitar, I use Guitar Pro and think it's well worth the money. That said:

The TuxGuitar Documentation page on sound has a couple points that may or may not help with your issue:

First, and more likely to be the issue:

Sequencer: Beside MIDI Port sound options in the Tools→Settings→Sound tab is also MIDI Sequencer options. In general, you should use “Real Time Sequencer” because it’s faster, but it needs Java Sound plugin to be enabled, which means it requires Sun Java to be installed. In case you use some other JVM, your only choice is “TuxGuitar Sequencer”. Don’t worry, it is not as bad as it sounds. :)

So, check which distribution of Java you have on your machine. If it's not Sun Java, the built-in sequencer may be slowing you down.

If that's not the problem, this may have useful options/toggles?

Java Sound: Java Sound plugin, relying on the soundbanks, is still available in the form of the “Java Sound Api plugin”. You can adjust and change the soundbank with Configure button in the plugins dialog.

1
  • Thank you very much – ggcg Dec 23 '20 at 17:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.