2

So, I've been using Logic Pro X for some years now, but since I updated my MacOS I've come across an issue I never had before.

Before updating my MacOS, Logic Pro X was working fine; I was mostly using software instruments (the ones you can download directly from Logic itself, no additional libraries).

After swapping my HDD for an SSD and updating to Catalina OS, Logic started asking to download additional content every time I opened it; strangely enough, it never actually "finished" downloading anything. It kinda did, and it spent hours downloading tons of stuff, but once I started the program again, it asked to download the exact same things.

As this was getting a bit annoying, I decided to tinker around and try to solve it myself. I guessed the libraries were outdated, something was not being updated properly, or something of the sort... so I tried the following:

  1. Deleted stuff in "Library/Application Support/Logic", following some thread I read, and assuming that this would force Logic to re-download all software instruments. Did not work.
  2. Deleted the Logic application, and re-installed again. The program picked up at the same place, with the same issues. Did not work.
  3. Deleted Logic, deleted all stuff in "Library/Application Support/Logic", re-installed the program hoping to get a clean start. Logic asked to download all stuff, but reacted the same way as it did before trying any of the solutions. Did not work.
  4. Restored the Logic application and the content of the aforementioned "Library/Application Support/Logic" from an older Time Machine backup, from a time when things run somewhat well... Did not work.

Now I'm at a point, after having tried these things, where Logic not only keeps asking for downloading additional content, as it did before, but now MOST SOFTWARE INSTRUMENTS ARE NOT EVEN PLAYING! When opening one of the first Logic projects I did, where I didn't use many fancy additional instruments, it seems (not 100% sure of this theory, though) that the only software instruments being played are actually Garage Band instruments:

  • Retro Rock Kit (drums)
  • Hard Rock (guitar)
  • Glassy FM Lead (synth)
  • Classic Electric Piano (electric piano)

However, I don't get any sound from any of these:

  • Picked Bass (bass)
  • French Horns (brass)
  • Trumpets (brass)

Has anyone had similar issues as the ones I'm having, and managed to solve it? It's starting to drive me crazy as I can't actually work on any project whatsoever... Any tips?

Thanks in advance!

EDIT: Aside from upgrading the OS, I swapped and HDD for an SSD.

9
  • Which release of Logic Pro X are you using?
    – Aaron
    May 26 at 7:12
  • I'm using version 10.0.6 (sorry I forgot to mention in the main post)
    – Johanovski
    May 26 at 7:17
  • Do you have the option of upgrading to the current release: 10.6.2?
    – Aaron
    May 26 at 7:23
  • Nope, I'm afraid I'm stuck with my current version... Got this one through a different user I have no access to now, so I'd have to buy it again. :___)
    – Johanovski
    May 26 at 7:27
  • 1
    Here's a guess: you're using 32-bit software instruments. Catalina requires 64-bit code.
    – Aaron
    May 26 at 7:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.