2

I am learning to write Sibelius plug-ins by working my way through the ManuScript Language Reference (see File > Plug-ins > ManuScript Language Reference). Unlike other scripting languages I use (e.g. Xcode, Unix and Linux shell scripts, js), ManuScript is music-specific and the Sibelius documentation is excellent and easy to follow. However I hit a snag editing code in the Run method, using this code snippet on p.7

code snippet

Still in Edit mode, I clicked the Check Syntax button. It displayed the following message 'the syntax is correct' and when I exit Edit mode and run the Run method, the following appeared

    Message ‘1 + 1 = 2” 
    OK 

I closed the three dialogs by clicking OK, OK again then Close. When I ran the amended plug-in, Sibelius crashed. On the MacBook Pro I got the rolling rainbow beach-ball and the (MacOS) message

    Sibelius (not responding) 

When I force quit Sibelius the message in the Run window remained until I clicked OK. At which point, the beach ball disappears but Sibelius appears to be still running (i.e. it can perform its normal non-scripted commands). Each time I try the above steps it crashes. I also tried it with x as a parameter in the Edit dialogue but this made no difference.

This looks like a bug but perhaps someone can kindly tell me if I have misunderstood something. Thanks.


Note. Tags I used for this question are not ideal but are the most appropriate available to me.


1

Whenever the rolling beach ball appears on a Mac it normally means a program has crashed. However while using ManuScript to edit a plug-in, the same beach ball seems to appear whenever the mouse is not in the relevant place. It immediately disappears whenever the mouse hovers over the ManuScript Message window. So this might be the normal behaviour in the ManuScript language.

Moreover, I progressed through the rest of the examples in the ManuScript Language Reference without incident so until I am told otherwise I will treat the rolling beach ball as a window status indicator while editing. It appears only when the mouse hovers over the wrong window.


NOTE. There's a better answer out there. It'll help other novices if I wait for it.


3
  • 1
    This answer doesn't seem to relate to the Run method. Did I misunderstand the question?
    – Aaron
    Jul 21 at 0:48
  • Aaron, I don't think you misunderstood the question. It's more a case of the answer not being one I initially expected. I tried to clarify the wording of the answer.
    – Greg
    Jul 21 at 2:56
  • Got it. Helpful if you'd accept the answer then, so it's clear you found what you needed.
    – Aaron
    Jul 21 at 2:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.