4

In my studio setup, I have a Yamaha P-115 digital piano and a M-Audio CTRL49 keyboard controller. Both are bulky, therefore I have one out at a time only. I use Bitwig under Windows as my audio workstation.

The digital piano is convenient to record ideas when I "hit the walls" of the 49 keys. But it has a problem. When I strike the keys as hard as I can on it, the recorded velocity is really weak. Significantly weaker than if I press the M-Audio keys with a reasonable force. I tried changing the curves from the keyboard using the available settings from the manual; this did not help at all.

Pushing up the track volume can be a makeshift solution but not viable in the long run, especially with instruments that have varying timbres depending on velocity.

The other solution would be to put a "velocity boost" on the software side. Something that would remap the velocity ranges from the input. The following possibilities came to my mind:

  • Adding a Note Velocity effect before the instrument in every track. It helps a bit, but I need to disable it in all tracks when I switch to the other controller for mixing and arranging.

  • Writing an input script from scratch that boosts note velocities before sending them to the workstation. Still requires some learning.

Would you have another possible solution? The ideal would be to have the velocity boost set up per MIDI controller rather than per track.

3
  • You need to tell us what your DAW is. This type of thing can easily be done in the Logical Editor* in Cubase. [They may have changed its name over the years, I've lost track, but it's been there since the late 90's] (just for Tim, if you read this - there's another book chapter in that)
    – Tetsujin
    Nov 16, 2021 at 19:46
  • My DAW is Bitwig Studio - I mentioned "audio workstation" perhaps it is not clear.
    – DavGin
    Nov 17, 2021 at 13:24
  • Ah, I missed it in the title. Sorry, I'd never even heard of it, so I've no idea of its capabilities. It's probably time for a dig through the manual.
    – Tetsujin
    Nov 17, 2021 at 13:27

1 Answer 1

1

You don't mention whether you suspect it to be a mechanical problem with the Yamaha's keybed (where all the rubber membranes and PCB contacts are). If so, it might be worth dismantling and giving it a clean with Isopropyl alcohol. You should be able to find a teardown video on YouTube.

If not mechanical, have you tried a factory reset on the Yamaha keyboard? It might seem obvious, but perhaps you've accidently input a key combination that's messed things up. Also, the manual states that:

Touch Sensitivity cannot be used for jazz organ, pipe organ, rock organ, or harpsichord voices.

Again, plain enough, but it might be a quirk of the keyboard's routine. I'd also check whether there's a local MIDI setting, and if so, perhaps try disabling or enabling it.

Another option is to use a VST plugin to modify the incoming velocity. Here's a freeware one:

https://www.codefn42.com/veloscaler/index.html

HTH

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.