Ableton Live 11
Launchkey Mini mk3
Win 10

Experience: zero (second day since I launched it).

I assign chain selector thing to the macros 1, but when I turn the knob, I change the volume of the first instrument. And knob 2 controls the volume of the second instrument. In all materials I found over the last pair of hours (both text or video), knobs control macros right away. The person assigns chain selector to macros, turns the knob, and the value changes there. In every single tutorial/guide/vid. It's just expected to work that way. Doesn't work for me tho, and I have no idea what I do wrong. Chain selector works correctly if I drag it around with mouse. It's just the knobs that do not what I expect them to do.

enter image description here

I'm pretty desperate as despite my internet search skills, I couldn't dig up any info at all about why this happens and how I switch the knob from controlling instrument volume to actually changing macros values. Every single piece of information covers how to map chain selector to macros, which I accomplished easily in a pair of minutes. I just can't control the macros itself. An assistance will be much appreciated (be easy on a rookie).

  • Since I'm familiar with LaunchKey Mini - Ableton Live puts it in so called "DAW" mode, which is a dedicated port. On that port, knobs on the controller have 5 modes... Device (for macro 1-8), Volume (for channel volume), Pan (for channel Pan), Sends (A, B) for channel sends 1-2, resp., and CUSTOM for whatever you assign via the LaunchKey JavaScript customizer.... To add to this... MIDI mappings usually OVERRIDE anything else that "just works". Jul 31, 2023 at 22:29
  • In other words, the LaunchKey Mini has 2 ports. One for regular MIDI,, and one for light diode feedback, which Ableton Live has a mini interface for... the 1st port is the "regular" MIDI port, the 2nd port is the "DAW" port. If you want to MAP MIDI, you will by default, override behavior of the Ableton-LaunchKey integration, which is something that is up to you. . Programming manual (full LaunchKey) says the only thing you should beware is setting CUSTOM knob mode to chan. 16, bc. it may interfere with the other port, but by default it's sending on channel 2 - check with SHIFT + TRANSPOSE Jul 31, 2023 at 22:37

1 Answer 1


Select the "Device" knob mode by pressing the Shift key + "Device" pad (fourth pad in the top row, the first blue-green pad when shift is depressed).

How the change may have happened

When you close the DAW, thereby turning off the "DAW" mode of the LaunchKey Mini, next time you run it with Ableton, it will reset to the default state of "Volume" knob mode

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.