5

I have a problem with dotted note chords in LilyPond, for example:

\version "2.22.2"
\relative c
{
    <f' g a c>4.\arpeggio
}

This produces: close spaced chord with augmentation dots extending beyond the vertical range of the notes

For the sake of presentation, I am wondering is there a method to avoid showing the dot under line 1?

1 Answer 1

4

Reducing the number of augmentation dots displayed for a close position chord can be achieved by changing the number of "extra" dots that can occur (from the default 3, to 1):
\once \override Staff.DotColumn.chord-dots-limit = #1

See this page of the internals for more details and related settings:
https://lilypond.org/doc/v2.22/Documentation/internals/dotcolumn


Depending on the particular voicing of the chord and where it sits on the staff, you might also need to move the dots up or down slightly:
\once \override Staff.Dots.staff-position = #1

See: https://lilypond.org/doc/v2.22/Documentation/internals/dots

1
  • Thank you, that was nice and neat~:)
    – Lei Peng
    Nov 11, 2023 at 5:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.