0

So I acquired a used electric guitar(Brand: Ibanez GIO, GS120906614 & IBZ1G guitar Amplifier) from an acquaintance and after researching how to setup and all, I tried playing and no sound came out of the amp/speaker, I made sure everything is connected proper and tried tinkering with the dials. Once I pressed the 'distortion' button, some sound came out but not the proper electric guitar notes i have heard in videos! I have a pair of headphones tried connecting but the same issue is persisting and i could hear proper static when using distortion. Is it an error on my part with tuning or will it be a amp issue and i should take it for repairs or can I do it myself (some skill in electronics repair)? Please help?

4
  • 2
    Have you tried the obvious thing an asked your acquaintance a) if it was known to be working when he passed it on to you and b) if so, are there any non-obvious things to do to get it to work?
    – user87621
    Dec 4, 2023 at 15:04
  • 2
    Certainly won't be a tuning problem! Go back to 'acquaintance' and explain the problem. Could be many things, but they'll have 1st hand knowledge as to how to set it up. Not really a diy job, I'm afraid!
    – Tim
    Dec 4, 2023 at 15:05
  • (op here)thank you for the advice, I willl do that. But i doubt anything will come of it since he just used it as a prop. but anyways i will ask him! Dec 4, 2023 at 15:36
  • 3
    I'd be inclined to take it to a music shop. This is one of those things it's really simple to work towards what is at fault… but you need two of everything, 2 guitars, 2 cables, 2 amps. It will take only a couple of minutes to figure out which is at fault - then they can investigate further, if it turns out to be anything other than the cable. They can even watch you set it up, to see if you're doing anything wrong. Stuff that would take 20 questions in text, 30 seconds by observation.
    – Tetsujin
    Dec 4, 2023 at 17:15

1 Answer 1

0
  1. Try a new cable
  2. Check the knobs and switches on the guitar and amp. Make sure the the knobs are not turned all the way down.
  3. Unplug the guitar cable from the guitar and see if you get a loud noise from the amp. If you do, then the problem is with the guitar.Take it to a repair shop.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.