3

I've chopped up an audio file into smaller pieces, selected them all and created a sampler track through the Convert To New Sampler Track feature in Logic Pro X. I've set the project to copy audio files and copy EXS instruments and samples into the project via File->Project Settings->Assets and checking off the appropriate boxes.

Every time I reload the project it gives me an error saying"EXS24 instrument '<filename>' not found.". How can I stop this from happening. I know how to relink the sampler track to the file, but it's annoying that I have to go through this process every time I open the project. Anyone have any ideas on how to fix this?

Here's what happens and here's how I fix it, but like I said, it's a fix I have to apply each time I load the project:

1) After loading the project I get this message This occurs after the project is loaded

2) Here's an image of the sampler track (it was derived from the audio track above it)

Sampler Track

3) Open the instrument settings

enter image description here

4) Reset the instrument

enter image description here

  • I'm not familiar with LogicX but am very familiar with Logic9. I'm not completely sure I understand what is going wrong for you but if I am understanding it correctly, it seems like you could just save the instrument as a preset, like you would find in the 'Library', and access it like any other preset. Again, I'm not really sure if this would be helpful, so that's why I'm suggesting in the comments instead of an answer. – Basstickler Jan 20 '15 at 14:38
  • I see what you're saying. Unfortunately it did not work. I went to the dropdown where it says User Default and I clicked on save as and then saved the preset. The same error message comes up when I reload the project though. I'll update my question so that you see exactly the process I have to do to fix it. – 02fentym Jan 20 '15 at 14:47
  • I'm thinking that you would want to save the preset in the original project, then open the preset on a track in the new project. It may be terribly obvious but don't forget to save once you have made the changes. – Basstickler Jan 20 '15 at 14:55
  • Just tried it. In the new project, it allows me to load the preset, but the underlying samples that are mapped to each key are not present. – 02fentym Jan 20 '15 at 15:01
  • What I see above is a little different than I was thinking but should work no different than what my suggestion would have done. I meant to suggest that you save the Track as a preset, not the instrument within the plugin, but I now suspect this wouldn't resolve the issue. It might be the way the presets are named, with ".exs_#" in the name. The extension being included in the name might be confusing Logic when trying to load the plugin. Maybe try renaming the preset without ".exs" in the name. I would also try saving another instrument and doing the same thing to see if you can replicate. – Basstickler Jan 20 '15 at 15:46
1

You need to go into the EXS24 instrument that you've created and "export" the instrument and samples and then reload from the exported EXS24 instrument.

The detailed steps follow, but first and overview. You are going to

  1. Export your EXS24 Instrument and save it somewhere (anywhere).
  2. Remove the plugin from the track.
  3. Reload it from your export.

Now here are the details:

  1. Copy and paste your .logicx package in the finder to make sure you have a backup.
  2. Open your .logicx project.
  3. Do what you have been doing to clear the error and get your EXS24 instrument working properly.
  4. Open the EXS24 Plugin.
  5. In the upper-right of the instrument you should see two buttons, "edit" and "options", click "edit"
  6. In the EXS24 Instrument Editor window that opens, find the "Instrument" menu along the top.
  7. Select Instrument->Export Sampler Instrument and Sampler Files
  8. A typical Mac OS X Save Dialogue will open. Create a new folder somewhere and save your EXS24 instrument inside it.
  9. Close all the EXS24 windows and get back to your main Logic arrange window.
  10. In the inspector (or in the Mixer) click on your EXS24 instance and get rid of it by selecting "No Plugin"
  11. File -> Save As. Make absolutely certain that "Copy the following items into your project -> EXS24 Instruments and Samples" is checked. If so, you can cancel the Save AS. If not, then check it and click Save.
  12. Do a Save As again, make absolutely certain that item is checked!!!
  13. Go back to your track, add an EXS24 plugin.
  14. Open the new EXS24 instance, At the top it should say Factory Default
  15. Click the "edit" button in the upper right.
  16. In the EXS24 Instrument Editor, select Instrument->Open
  17. Open the exs file you created in step 8.
  18. Close the EXS24 windows to get back to your arrange window.
  19. Save your project.

Now Logic should save your instrument and samples properly and the next time you open the project you should not be prompted to find the instrument/samples.

If this fails, try these folks http://www.logicprohelp.com/

  • Cool...yes, please clarify your answer a bit, I'm not quite following. Thanks for the initial post though. – 02fentym Jan 20 '15 at 6:34
  • Is your project saved as a "folder" or a "package"? – Matthew James Briggs Jan 20 '15 at 7:05
  • It's a package. – 02fentym Jan 20 '15 at 7:07
  • I don't know what went wrong the first time, but basically what I'm suggesting is try to get logic to do the right thing by getting rid of the instrument and reloading it. – Matthew James Briggs Jan 20 '15 at 7:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.