4

I have this physical connections:

                   "phones out"      "line in"
Guitar -----> Amp -----------------------------> Computer

And I was using Windows 7 with the following settings:

Playback devices --> Recording --> Line In --> Properties --> "Listen to this device" is UNCHECKED

Playback devices --> Playback --> Speakers --> Properties --> Line In: 100% (un-muted)

Those settings work awesome: I get 0 delay.
If I use the "Listen to this device" option instead, I get a delay of ~1000ms (horrible)


With that said, I wanted to put real time effects to the "Line-In", so I downloaded VSTHost and used this settings:

Windows settings:
-----------------

"Listen to this device" continues UNCHECKED

Playback devices --> Playback --> Speakers --> Properties --> Line In: now is muted


VSTHost settings:
-----------------

Devices > Wave devices > 
                          Input port: DS Line in
                          Output port: MME Microsoft Sound Mapper

But then I got the same delay as the one with "listen to this device" checked

Question: What am I doing wrong? how can I achieve the same zero delay but with VSTHost instead of Windows?

3
  • First off, try getting hold of ASIO4ALL instead of using MME. You will never get zero latency through any plugin structure, though you might get it down to something acceptable.
    – Tetsujin
    Commented Feb 28, 2015 at 17:15
  • How do I do that? (get hold of ASIO4ALL). Well I know I will never get 0 latency but Im already getting amost zero latency without VSTHost (using only Windows). I want to replicate that almost-zero-latency using VSTHost with a setup of no plugins. ie: input --> no plugins --> output
    – sports
    Commented Feb 28, 2015 at 19:01
  • I've installed ASIO4ALL for in VSTHost > Devices > Wave I continue to see the same MMEs and DSs for the input and output
    – sports
    Commented Feb 28, 2015 at 21:11

2 Answers 2

1

The latency may be due to the processing time required by the VST effects. To reduce latency, reduce the buffer size in VSTHost's audio settings as small as possible while avoiding audio dropouts. You might also try different audio drivers to find the one that provides the lowest latency.

1

You will need to get an audio driver that is designed for low latency audio. Usually this means an ASIO driver. If you can find a native ASIO driver for your sound card (e.g. Realtek ASIO for a Realtek card), then that is the best solution. ASIO4ALL is a generic ASIO driver which ties non-ASIO inputs and outputs together to work as an ASIO driver- but it is significantly less efficient than a native ASIO driver, as the input and output will each introduce their own additional latency. It is still better than trying to do this with a non-ASIO driver.

Your initial test setup sounds pretty strange to me- that you were able to set an input to be used as an output for monitoring. I suppose this must be a feature specific to your sound card, and it probably won't be available when interfacing with other software.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.