I recorded some MIDI using Cubase 5. The tempo of the recording doesn't match that of the underlying grid Cubase displays. How can I change the tempo (spacing) of the grid without affecting the duration of the notes? I would like to do this globally, not locally (time warp tool).

  • If I understand you correctly, rather than changing the grid to match the audio, you could set the global tempo to the tempo you actually played at (which will change the playback speed of the midi and not sync it up to the grid). Then use the time stretch tool to stretch the midi track so that it lines up with the grid, and it will be playing at the original tempo and lined up with the grid.
    – Some_Guy
    Commented Nov 30, 2016 at 12:25
  • If you recorded without a metronome, you'll probably have to split the midi into a couple of sections and scale them slightly differently, as small changes in tempo will make the track get gradually out of sync with the metronome. Also you could use beat match to work out the tempo of the original midi exactly.
    – Some_Guy
    Commented Nov 30, 2016 at 12:29

2 Answers 2


Change your track settings from tempo based to time based. Then change the tempo of your project to fall with your recording. It is the little icon with the clock (when your track is time based) or a note (when it is tempo based). Then you can revert your track back to being tempo based.

  • Do you mean change to time based where it says "Select primary time format" in the tooltip? Once I changed it there, how can I change the tempo without affecting the notes (without slowing down or speeding up the song)?
    – Cur
    Commented Mar 25, 2015 at 15:19
  • If you change your track properties from being tempo based to time based (change the icon from the little note to clock) then your track will not be affected by changes in the project tempo.
    – Chris
    Commented Mar 25, 2015 at 15:27
  • Mute all but click, map tempo of recording for whole track. Import audio after. And as Chris said...use time based, not tempo.
    – D3l450ul
    Commented Jun 8, 2016 at 0:58
  • Keep in mind this setting is not available in all versions of Cubase. Make sure your version has this setting.
    – Charmander
    Commented Jul 11, 2021 at 16:22

There are two ways to get an audio part and tempo track to line up. Since you're looking to change the tempo to match the audio, the first method is what you're looking for.

Method 1: Change tempo to match the audio track

  1. First, select the audio part you want to get the tempo changes from.
  2. Then, look for an item in the audio processing menu in the main project view that brings up a dialog where you can either tell Cubase to "detect beats" or manually tell it how many measures elapsed over a certain amount of time. This dialog allows you to have Cubase automatically add tempo changes to match your audio track's tempo fluctuations with great precision.

Method 2: Warp the audio so it stays with the project's tempo track

In the event that you would like to instead warp the audio to match a steady tempo, then the second method, using hitpoints to create audio warp markers, will appeal to you. To do this:

  1. Double-click the audio part that has undesirable fluctuations in tempo. This will open that audio part in an audio part edit window.
  2. Detect hitpoints
  3. Generate warp markers from hitpoints
  4. Warp the audio to match the grid
  5. If these auto alignment results need tweaking, then you can add your own additional hitpoints/warp markers afterwards and click-and-drag warp them yourself to match the grid.

I have personally used these methods in Cubase 7 and Cubase 7.5.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.