2

I'm studying the manual atm and the feature that I tried recently is splitting MIDI regions by pitch. It works fine, but when I removed all tracks that has been created as a result I'm stuck with 16 non-used channels in the Mixer and I have no idea how to delete them. I tried using delete/backspace, I have checked the menus, I even checked the manual when it comes to MIDI channels :(

Can anybody help me?

  • Have you tried using the apple command key & delete. – Sy_UK Jun 7 '15 at 13:49
  • Yeah, I tried it bro, cmd+delete deletes a currently selected track, not a channel – Maciek Czarnik Jun 7 '15 at 17:01
  • Add a screenshot please? Are there no - buttons next to the original channel source? Like when adding seperate stereo channels from a main channel source in the mixer. – jarryd Sep 7 '15 at 19:50
1

It sounds like you are running up against a bug, because when you delete a track in the track view, the corresponding mixer channel in the mixer view should disappear also.

If you don’t have any content in this document, I suggest you just create a new document. (One of the big advantages of Logic is the templates, so choose the right template for what you are doing carefully and you may not even have to manage any tracks.)

If you do have content in the document, one thing you can try is to Save the document, then Close it, and in Finder, first duplicate your document to make a backup, and then context-click (2-finger tap or right-click) the original document and choose “Show Package Contents” from the pop-up menu and the document will open as a folder. Inside, there are files and folders. Go into the “Alternatives” folder, then into the “000” folder, and find a file called “DisplayState.plist” and put that file in the Trash. Then close the windows you just created.

The “DisplayState.plist” file contains a bunch of options for how your document should be displayed by Logic, and it is the source — unfortunately — of some Logic Pro X bugs. By putting it in the Trash, you reset the non-content parts of your document to being a new document.

Then open your document in Logic and with any luck the phantom channels will be gone from the mixer.

1

An old post but I just ran into this problem. Open midi environment window from the 'Window' menu (command+0), select the 'MIDI Instr.' layer in the drop down at the top left of the window.

Here you can find and delete all the midi channels you don't want.

0

I haven't used Logic, but most DAWs are similar. I use Live 9. Try highlighting/selecting the channels in the mixer view, and right click - deleting them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.