4

I have a HP302 Roland digital piano. It has a usb connector that easily plugs into my computer. The problem is, Reaper is not picking up the piano. It sometimes will say something along the lines of:you've disconnected Roland digital piano but that is it. Im not looking to spend money on an actual MIDI keyboard since Im on a budget. Why won't Reaper pick it up when Garage Band picks it up fine? I would use the audio recorded in Garage Band and upload it in Reaper but for some reason, when I play it in Reaper, the recording is much slower and at a strange pitch. So I feel my only option is to record in Reaper itself. Does anyone know how to get Reaper to detect the piano?

Edit: @Caleb Hines: here is what it looks like now. Im following the tutorial by Kenny here http://www.reaper.fm/videos.php#ztr7B-PrUHY and if you go to the 33 second mark, the MIDI is detected there. The one problem solved so far is that at least reaper is detecting the piano. I got rid of the screenshot. This site needs 10 reputation points for me to post 2 links.

Still trying to get it to record. I tried recording, but Reaper used the built in mic on my computer instead. Ok it's recording now but I cant hear it when I play the recording back. Here is what I have right now: enter image description here

Edit 2: @Caleb Hines:Ok so I did have a VSTi connected to the track but I did not have an output so that works now. Thank you! But the solution you mention at Reaper playing at a slower and weird pitch being fixed with adjusting the rate:

  1. Is there a way to adjust the rate by typing in the numbers instead of adjusting the switch itself? The switch jumps around a bit and itd be great to have some precision over it.

  2. The recording came from Garage Band. I have a piano recording of a song and was hoping to embellish it with different layers of sound. But when I insert the Garage Band media file, it plays at a strange pitch and much slower. If I use the rate to fix it, it still sounds off, but a bit better. Have you tried inserting a Garage Band file into reaper and listen to it playback there? It's also happening with my VSTi actually. Im using Native Instrument's Massive, and Reaper plays the sounds at a lower pitch than I configured them to be

  • There's lots of possible things that could be going on here... It's hard to troubleshoot technical problems in one answer. To start with, if you select Ctrl+P (Options > Preferences), then select Audio > MIDI Devices in the left pane, does the device show up under MIDI inputs? Is it marked as Enabled in that window? Also, if it's spontaneously reporting that you've disconnected the device, it could be that there's a loose USB connection. – Caleb Hines Apr 10 '16 at 2:23
  • I did try the options > preferences thing, there Reaper isn't picking up any midi device. Like see here this is what it reports when I unplug it sometimes: "The following MIDI inputs could not be opened: Roland - Roland Digital Piano." It calls it a MIDI error. So there is some level of detection but it wont show up. Wait Reaper is picking it up now? I'll get back to you about this, Im going to test it – helloall Apr 10 '16 at 3:43
  • Random disconnects are typically caused by defective USB cables/connectors, but if Garage Band sees it, it's not a hardware problem. – CL. Apr 10 '16 at 8:00
1

You mention that when you record with a microphone, the playback is slower and at a strange pitch. I'm guessing that's caused by the "Rate" slider. It's the green bar in the center of the screenshot (to the right of the word "[Paused]"). In your screenshot, it says "Rate: 0.949" which may be causing your recording to play back slowly.

As for the MIDI playback causing no sound, you'll need to check at least two things. I haven't watched the video you linked, so I don't know if it already mentions these or not.

  • In the [FX] dialog for your track, you need to have a VSTi selected (a virtual instrument) in order to produce sound. If you don't have any custom VSTi's, you can try playing with Reaper's built-in ReaSynth. It'll give you a cheesy 8-bit synth sound sound, but it's a starting point, until you start collecting your own VSTi's.

  • Back in the Preference dialog, under Audio > Devices (not MIDI Devices), you'll need to have a proper output device selected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.