1

Anyone had any luck with installing a Scarlett 2i2 on an Asus Chromebook c201 yet?

A little bit of back story. All I want to do is record tracks. I got myself a small mixer where all my instruments (guitar, bass and elec drum) are plugged in and I get the output into the interface. Now, all I needed was a cheap laptop so I could record whatever gets in the interface.

I bought the Asus Chromebook c201 and tried to install the interface using a crouton setup with Ubuntu 14.04 (trusty). After I fiddled with the settings and other nonsens, I finally got Audacity using JACK with ALSA driver working. I started Audacity, pressed record, and voilà! IT WORKED!

I recorded one test thing and it was late so I unplugged the interface and took the Chromebook to play with it a bit, you know, just browse and stuff.

Anyway, I got up early and I wanted to do myself some recording since I got the setup ready and all! Nope. All I was recording was a loud waveform, and I mean loud, like it's just a really loud noise. Nothing else, not even a bit of guitar or something. Just 100% noise. I played with volumes and gains on the interface, nothing to do.

I started the install over 4 times trying different things every time, but alas, even thought the software seems to work, I can't get past this loud noise.

I thought that the crouton installation was messing with my card so I reinstalled the Chromebook with factory default and tried one of the online web application to record. Since I can see the 2i2 interface in the sound options of ChromeOS, I thought I could record anyway but with some delay perhaps. Nope, still this loud noise.

Maybe it's the hardware? Well, I did another test and it was with my Windows 10 machine. Installed the Focusrite's driver, setup Audacity, and it works pretty well. The recording are all great. The interface seems to be in working order.

I really don't understand what happened between the moment I went to sleep and the morning after where everthing went to hell.

Anyone has any clue of what I may be missing here?

  • If it was a windows pc I would say that windows drivers were installed after restart of the computer, but I don't know anything about Ubuntu... – papakias Jun 7 '16 at 14:46
  • There's an Ubuntu stack that is probably a better place for this. This is more of a computer question than a music question. – Todd Wilcox Jun 7 '16 at 16:03
  • 1
    Yeah, thing is, this is a very niche problem though. I asked in ubuntu / chromeos and music forums / stacks, but everyone is bouncing me out lol. I guess I'll just continue my tests and find someone maybe having this problem one day! Thanks anyway! – Allov Jun 7 '16 at 16:49
  • 2
    Lets keep it here, I think this "stack" can benefit from more Linux related Q/A (as long as their are related to music creation). – elcuco Jun 8 '16 at 13:42
2

I am not a fan of Jack. I find it complicated, and besides when Jack is running, only Jack applications can use it. Which means - you make a pause while recording, you cannot listen to music nor watch stuff on YouTube (instructional videos is another example).

You don't really need Jack if you are using Audacity, this will simplify your setup.


To the real answer -

Try running from the command line alsamixer and see if some line is "too high". Its possible that you the input channel you are using is over amplified.

Also - be sure to user alsa's loopback modele (sudo modprobe snd-aloop - which is persistent after boot, no idea how) instead of using PulseAudio's loopback module (as described here in Ask Ubuntu), you want the mixing being done by the Audio card, and not in software.

  • Definitely going to check this out. Is there a way to prevent Audacity from using jack? I remember it trying to find it and crashed because it wasn't there. – Allov Jun 8 '16 at 13:38
  • If jack is running, (on my setup...) the only way to make sound is through jack... so. Don't start jack :) – elcuco Jun 8 '16 at 13:41
  • When I run alsamixer, it says that this device does not have any controls :/ Also, snd-aloop doesn't seem to be installed and I've read a bit, and it seems I need to recompile the kernel? Do you happen to know if it comes with a crouton distro? – Allov Jun 8 '16 at 23:13
  • Alright, so I installed the pavucontrol which I could play with the volumes. While I could drop the really loud noise, I still can pickup anything from any kind of input. I can see the interface picking up the guitar and mics, but it doesn't get to the computer. Still works fine on windows. Could it be the usb port? I've tried both ... I've plugged in a mouse and it works... for what it's worth. – Allov Jun 8 '16 at 23:42
  • That's the problem with Android/Chromebook kernels - they lack all the needed facilities found in "normal" linux distros. You need to use a better OS - as the drivers/low level facilities you are looking are not something you can install as a "chroot". – elcuco Jun 9 '16 at 8:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.