1

So, I have this problem that always that I try to use my PC as a guitar effects modeler, a virtual synth, etc. I always get delay from what I play and what I hear (like 0,2s or so). The DAW I'm using is reaper. I don't think the computer's hardware is causing it either, as its processor is an Intel Core i7. Ideas or clues why is this happening? Are there any settings I need to change?

  • 1
    'latency' is the keyword. You'll always get some, but with the right audio hardware and drivers, you should be able to get it down much lower than 0.2 seconds. What computer and what audio interface are you using? – topo morto Dec 6 '16 at 11:37
  • 1
    One of the most important things that no one seems to have mentioned yet is your buffer size setting, which corresponds exactly to latency you're getting. The lowest buffer size setting you can use without causing processing overload will give you the lowest latency. – Linuxios Dec 6 '16 at 16:02
1

First of all, make sure you've installed all the drivers that are needed and/or update them.

I used to have the same problem with my Focusrite Scarlett 2i2, even after I had all the drivers needed installed. The problem was that I was trying to listen to the outcome through the monitors of my PC, which were not connected to the audio interface (focusrite). To solve this, I usually connect my headphones straight to the interface. The best solution would be to get good monitors and connect them to the interface, but this requires some money, in order to be some decent ones.

1

Latency is not about the power of your computer. It's about the soundcard, its drivers and their settings.

If you have only onboard audio, try installing the free driver ASIO4ALL. But the real answer is an additional audio interface (sometimes generically referred to as a 'soundcard' even when it's an external USB device) with a dedicated ASIO driver. This will enable sub-10ms latency.

  • Right, "drivers" isn't good enough: you need native ASIO or ASIO4ALL if a native one is not available. The regular shared-mode audio drivers have too much latency. One trick I learned is that you need to set the ASIO drivers to whatever the native sampling rate of the chipset is. If your onboard Realtek is 96k, setting to 48kor 44k requires down-sampling and this adds latency (for me it was around 3ms). – Yorik Dec 6 '16 at 16:28
0

I had a problem with Reaper and a FocusRite interface where the vocal had a very slight delay while recording. I found that muting the track eliminated the delay and stopped annoying the vocalist as well as the engineer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.