3

I have recently bought a used Casio LK-41 (Japanese Language). It has a Midi Usb port. I have been trying to connect it to my Dell N4050 laptop to use it as a midi controller device with Reaper, but it is not connecting properly.

I have tried 4 different midi cables of various lengths, but no luck. I have tried to connect it to another laptop as well, but I get the same error.

I have tried tons of different drivers; none of them work. In the device manager, it should show under Sound and Game Controllers, but it always appears as an Unknown Device under Universal Serial Bus Controllors.

I used to have Windows 10 64-bit; I switched to Windows 7 32-bit, then to Windows 7 64-bit in a hope to resolve the issue, but all in vain.

I have done a lot of research. But I haven't been able to find any solution. I would really appreciate if a professional would help me out please!

P.S. I am considering the following solutions at the moment: 1. Switching to Windows XP 32-Bit. 2. Joining 2 Midi Cables in order to attach the Piano to two USB ports at once (In case, if it is an issue of the piano not getting enough voltage).

  • Why "MIDI cables"? Do you mean "USB cables"? – CL. Jun 17 '17 at 9:03
  • What are the properties of that unknown device? Especially the hardware IDs (if they exist)? – CL. Jun 17 '17 at 9:04
  • Yes, I meant USB cables. The one with Square shape at one end. It is also used for printers. – Ali Arslan Jun 18 '17 at 8:01
  • Properties: Windows has stopped this device because it has reported problems. (Code 43) – Ali Arslan Jun 18 '17 at 8:02
  • {36fc9e60-c465-11cf-8056-444553540000} Port_#0002.Hub_#0004 PCIROOT(0)#PCI(1A00)#USBROOT(0)#USB(1)#USB(2) usb.inf:Generic.Section.NTamd64:BADDEVICE.Dev:6.1.7601.23529:usb\unknown – Ali Arslan Jun 18 '17 at 8:04
1

That unknown device error indicates that the OS cannot communicate with the device, even before the actual driver gets involved. And if the keyboard does not work with multiple cables and PCs, then it's the keyboard itself that is broken. Replacing cables or OSes will not work, you have to replace the keyboard.

  • I had come to the same conclusion too. P.S. Just tested the Keyboard's USB port with a tester, it is live (the bulb lit up), it is supposed to be this way? I have managed to convert Audio from the Piano to Midi signal through Reatune plugin in Reaper. But it has a lot of latency and it is not accurate. Are there any tried and tested solutions for Audio to Midi? – Ali Arslan Jun 18 '17 at 9:31
  • I don't know what your tester tests. As you've seen, audio-to-MIDI usually isn't worth it; a keyboard is much simpler, cheaper, and more realiable (if it works). – CL. Jun 18 '17 at 10:39
1

I found this ..

I have the same problem, I cannot use this advice however as my keyboard does not even show as unknown.

But this looks like a workaround if you have a little knowledge

Best of Luck

1

My MIDI keyboard recently stopped working after I moved with it so I unscrewed the bottom plate and took a look at the insides. Unplugging and plugging the ribbon cables back in fixed it. Try looking at the PCB to see if there might be some corrosion as well. "8-bit Keys" on youtube has a bunch of videos about fixing old synths.

1

It could be an issue with the USB port on your laptop. It doesn't necessarily mean it's broken, but have you tried checking to see if there are updated drivers for the USB ports, or your laptop's chipset?

I have a Samson Graphite M25 that for some reason will work in certain USB ports and not in others. I found out that some USB drivers were missing for these ports. While other devices worked fine, in particular, I was having issues with the USB 3.0 ports -- they were not supporting this device properly, though other devices built for USB 3.0 worked just fine.

Likewise, verify that your USB MIDI keyboard is able to be supported by newer USB ports. It would be the worst if it can only interface with USB 1.1 and all you have are USB 2.0 and 3.0 ports!

1

Have you tried the official Casio driver from their web site? [Drivers] Windows Vista® (32-bit)/®7(32-bit)/®8(32-bit)/®8.1(32-bit) - Version 1.2

So far as I can see, they only support Windows Vista to 8.1, 32-bit only. Presumably, it's an old model. But you might want to search harder on their web site just in case I have missed something.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.