1

This is more of an audio recording question but I'm looking for any help I can get. I have a shitty setup, audacity and snowball microphone, but they haven't had this problem anytime since I've used them.

The latency changes with every recording, so it is impossible to correct for. This makes it impossible to record.

EDIT: So exactly what is happening. I'll go to record something and there is latency. So I go through the typical motions of how to correct that based on what little I know. I create a click track, play the click track out loud and record it, then measure the distance between when the click occurs and when it was recorded in milliseconds with the cursor. I then go to edit>preferences>playback and set the latency correct to negative the number I measured.

If the latency is roughly the same every time then this fixes it to a certain degree of precision. Recently, and I've never had this problem with this setup before, the latency has been varying by about .1 seconds every time I do the click track thing. I'll measure .145, plug in -.145, then still notice latency so I do the test again and now it is .245. Then is goes to .128 or something. It makes it impossible to record coherently.

  • We will need a lot more information before we can help. What is happening and what are you hearing and seeing that is leading you to say the latency is changing? – Todd Wilcox Aug 26 '17 at 23:04
  • Can you explain what you mean by "there is latency"? Are you monitoring the mic through the software? Are you using a dedicated audio interface? If so, which one? – Todd Wilcox Aug 26 '17 at 23:22
  • Just audacity and a usb mic. If I play one track out loud with the mic right next to it simultaneously recording another the two tracks do not end up synced during subsequent playback. – BoddTaxter Aug 26 '17 at 23:26
  • That's pretty common. I guess with dedicated interfaces and better software the software reads the one way latency through the interface and adjusts the recorded samples to line up automatically. Back in the day we would nudge stuff to the left the necessary number of samples after making a recording pass if necessary. But if you are separately tracking to a click, each pass of a different track will be exactly the same amount of time behind the click, so there no need to do anything to correct for the recording latency. – Todd Wilcox Aug 26 '17 at 23:32
  • 1
    If you've got an existing multitrack recording that you've made and you're trying to mix it and running into trouble, you should describe that in detail instead of what you have here. Also note that your click track playback and record test does not measure recording latency. It measures playback and recording latency at the same time. Playback latency is affected by many things including any plugins present, even on other tracks. You're probably worrying about something that's not actually a problem. Actual problems you might have can likely be fixed with better gear. – Todd Wilcox Aug 26 '17 at 23:44
1

We managed perfectly good multi-track digital recordings not THAT long ago when all soundcards had high latency - over half a second. The only restriction was that we couldn't monitor an input through the audio engine while recording. You either looped the input straight back to your headphones BEFORE it reached the audio interface and got digitised for the computer, or you didn't bother with monitoring the input at all.

Your Snowball isn't THAT crappy, but its USB connection isn't going to be low latency. And, unlike some USB mics, it doesn't seem to offer a direct analogue output, for input monitoring while recording (which would require an external mixer anyway). So, for a start, don't have the speakers on while recording, don't let the mic 'hear' the existing tracks. Use headphones.

I don't think the latency figure is jumping around. But your recording method is flawed. You shouldn't be having to make manual offsets to compensate for latency. You need a method that avoids the latency problem altogether.

0

For anyone googling this in the future I found a temporary fix. I set the audio to buffer, located right above the latency correction, as low as possible. From what I understand this gives the computer less time to process each sample of audio. So the CPU has to work harder and faster. This means less inherent latency because samples don't take as long to be handled by the computer, but the computer has to work harder. It seems like my computer can handle the extra load. Doing this gets the latency variance down to .01s, which is less perceptible.

This is just a band-aid and isn't really addressing the core problem. If anyone else has a solution please post it.

  • I guess the interesting question is how to apportion the blame between hardware and OS. For what it's worth, I have found hardware can be a factor. I have a Zoom H4n that also functions as an audio interface and have measured latencies varying by as much as 200ms. On the other hand a Scarlett 2i2 hooked up to the same laptop predictably gives me the same latency to within 1ms. – Bruce Fields Oct 26 '17 at 16:36
0

ok this things are easy to do and really common. the audiobuffer is growing with my projects. here some general steps for tighter recordings

1.Powersupply Always play with your Macbook connected to the power supply, especially when using an external audio interface and / or MIDI controller. To make sure your Macbook is properly grounded, use the extension cable of the power supply. 2.USB HUBS Use only USB hubs that draw power from their own external power supply. They are known in the market as powered USB hubs. If you use an external USB audio interface, do not connect it to the USB hub. Audio interfaces require the largest amount of power and computation, thus they must be connected directly to a free USB port. You may connect all other external devices to the USB hub into another free USB port. 3. wifi and bluetooth switch it off! 4.energie saver go to sys.settings and switch to never sleep 5. Updates make sure all is up to date 7 Graphics switch off auto graphic switching 8 now we go to the audiopref. Depending on the processing power of your computer and the amount of calculations needed for your application, a buffer size of 256 or 512 samples at a sample rate of 44100 Hz (on Mac OS X 10.9 or higher, we recommend 48000 Hz instead). A buffer size of 256 samples is a good starting point. Decrease this value to 128 samples if there is a noticeable lag between your actions and the audio, for example when playing virtual instruments live with a keyboard. Increase to 512 samples if you experience dropouts in the audio playback. so if your recordings are done you can go to higher sizes with no problems. but if you want the real shit use a really good interface for ultra low audiolatency and apples iac bus and mtc to sync your daw perfect in time. trigger only start without clock can be useful with midi, it is no problem to adjust the right startpoint. it becomes an issue, if the record is drifting in time. In your case it sounds like your monitoring setup is not right. try some pre and post records to find the bug. your soundcard is also a possible point... drivers and firmware up to date? cheerz

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.