0

I have no idea if I've just receive a defective product but I've noticed some strange goings on with my MIDI controller.

Sometimes when I plug it in, the 'boot up' light sequence never stops and I have to re-plug it a few times before it works. Then when I open my DAW, it sometimes just doesn't pick up any input so I have to close my DAW and re-plug it again (because re-plugging it while my DAW is open will cause the DAW to freeze). And talking about freezing, my DAW will also sometimes freeze for no reason and it can only be unfrozen by unplugging the controller. Then of course I have to restart my DAW, which is awkward.

It's been like that since I got it (a few months) and I'm wondering if anyone else has had similar issues.

Just some more details: It's a Novation Launchkey 49 MK2 and I'm using FL Studio 12.4.2 (but the problem also occurs with the Ableton Live 9 Trial). I've had it for around a month and I am using the original cable (the problem occurs with both USB 3.0 and USB 2.0 ports). I've updated it's firmware, and the problem occurs on both the 32 bit and 64 bit versions of my DAW.

  • if i were you, i'd just contact the manufacturer. – Stephen Hazel Aug 28 '17 at 16:01
1

Upfront it seems like a defective product, i.e. the boot sequence alone seems to indicate that, as well the problem happening with two different DAWs.

But here's a few things you can check to be on the safe side, before returning the controller to the shop:

  1. You don't give details about the MIDI setup on the computer side. What MIDI driver is being used, e.g. Windows native driver, Novation specific? Have you tried completely removing and reinstalling the driver?

  2. Monitor MIDI traffic in the system. If you don't already have a MIDI monitor you can try MIDI-OX (www.midiox.com).

MIDI data on it's own would not likely hang a DAW, even if it is giberish. It depends on your system's capacity, of course, but I've had configurations with massive amounts of data back and forth and have never seen a system hung because of excess MIDI data. But may be some combination of events (e.g. massive system exclusive messages) may indeed flood the system beyond its capacity.

Anyway, by monitoring traffic you may get a better understanding of what's happening and, worst case, get better arguments to return the defective product (if that's indeed the case).

  1. Check the controller surface configuration on the DAW side.

The Launchkey has sliders and buttons and all that, so it should have a proper controller surface configuration on the DAW. Make sure you follow the necessary steps to set this up as per the manufacturer instructions. Again, this does not explain the described behaviour (at worst, the buttons and knobs would not work), but it's worth checking.

If all this fails (I'm guessing it will), it's back to the shop...

|improve this answer|||||
  • It turns out that the cable that was shipped with my controller was faulty. I used another cable I had lying around and it works flawlessly now. However, I'll mark your answer as correct since you clearly put some effort into it and it looks like it could help other people. Thanks anyway! – Pyroglyph Aug 31 '17 at 14:07
  • Duh, how could I forget to remind you about checking the cable!? Glad you solved it and thanks for the (undeserved, really :-) good mark. – José David Aug 31 '17 at 15:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.