1

Recently I went to continue working on an orchestral score that’s been sitting on my drive for a couple months, but when I opened it up and started playback, the volume began jumping up and down randomly like a roller-coaster, affecting most (but not all) staves. There’s nothing visible in the score that could explain it: no hidden dynamics or other text or symbols, nothing bizarre in the Mixer, etc. The score played back just fine the last time I worked on it.

A few hours of troubleshooting narrowed the problem to the score itself; the issue doesn’t replicate in any other score, and all other computer audio (such as music playback) sounds fine. I tried switching audio interfaces (ASIO vs. WASAPI vs. DirectSound, my PreSonus Audiobox USB vs. plain computer audio, etc.), verifying the cables, restarting Sibelius and rebooting my computer, etc. – nothing worked.

Finally, I isolated one particular sequence in the score where the problem is especially noticeable and I then created a new score from scratch in which I replicated the section down to the last note, using the same playback configuration and Mixer settings as the original score. Whilst playback of the original score continues to glitch, the second, new score plays back just fine. However, if I copy elements (such as a staff) from the original score into the new one, the problem then infects the new score as well.

I’ve saved both files onto my Dropbox, linked below:
» Excerpt 1 – original, glitchy.sib (120 KB)
» Excerpt 2 – recreated, no glitch.sib (48 KB)
(If anyone knows another/better way to attach files to a Stack Exchange post, please let me know.)

To describe the problem as heard in the above-linked “original” file: playback starts too quiet (as if volume was at 30%) for the first bar, then jumps to full volume for the second bar, then falls back down again for the last two bars. The second file (“recreated”) plays back at an even, normal volume. (In case it’s relevant, the sound library I use in these files is LA Scoring Strings v2.5 for Violins I and II, Viola, Cello I and D.Bass, and Sibelius Sounds for Cello II. The volume glitch occurs with both sound libraries, so this isn’t exclusive to LASS or anything.)

So far, all I can think of is to recreate the entire score note-for-note, which would take an eternity.

So here’s my two-part question: a) does anyone know what might be causing this bizarre volume glitch, and b) is there any way to fix it in the original score?

Specs:
Sibelius 8.2
Affects all my sound libraries randomly
Windows 8.1 Pro (x64)
Audio interface: PreSonus Audiobox USB (using ASIO driver)


Update 1:

Following @brian-thomas’s suggestion in the comments, I tried playing both scores (linked above) back in General MIDI, with interesting results: the volume-jumping went away in the first score, but it played evenly at a much lower volume (maybe 50% or less) than the second score, which plays at full volume. However, I lack any MIDI sequencing software (or knowledge) to test this avenue further.


Update 2:

Following Brian Thomas’s latest suggestion, I’ve exported both excerpts as MusicXML files (linked below) and run them through this difference-checking site, but I don’t know much about MusicXML so I can’t tell for sure whether the answer is in there. All I see are minor differences in formatting/layout (margins, font sizes, etc.), which I don’t think would affect the playback.

» Excerpt 1 – original, glitchy.xml (60.2 KB)
» Excerpt 2 – recreated, no glitch.xml (60.2 KB)


Update 3:

It seems the problem is with my custom House Style specifically. I exported the original score (the full one, not the above-linked excerpt) to MusicXML and imported it back into a new score. The problem was gone. Yet when I import my custom House Style, the problem returns immediately. Hitting Ctrl+Z to undo the House Style import gets rid of the problem again.

So a messed up House Style is the problem. Is there a way to get rid of that? Can you reset a House Style?

  • 1
    If you export the two score portions to MIDI and then import them into a sequencing program, can you get clues from that? I can't try this myself as I only run Sib 7 and don't have any sequencing sw at all. Also, do you get the same problem if you use General MIDI sounds rather than sample-based playback? – Brian THOMAS Sep 8 '17 at 12:12
  • Thanks for the suggestion. Playing the scores back with General MIDI gave me interesting results: there’s no more volume-jumping, both scores play back at an even volume; however, even with identical Mixers settings (volume sliders in same positions, etc.), the original score plays back only half as loud as the recreated score, which plays back at full volume in MIDI. Unfortunately I don’t have any kind of sequencing software either, so I can’t test that. – Walter Sep 8 '17 at 12:54
  • Export as MusicXML and do a file diff? – Brian THOMAS Sep 8 '17 at 14:15
  • Thanks for the suggestion. I’ve updated the OP with Update #2. However, I don’t know enough about MusicXML to compare them well; all I see are minor formatting/layout differences that shouldn’t affect playback. – Walter Sep 8 '17 at 16:45
  • I wondered if you export your glitchy score to MusicXML and then reimport it, is it still glitchy? – Brian THOMAS Sep 9 '17 at 16:16
1

So I finally identified the problem as a messed-up House Style. I use custom Playback Dictionary entries and other customizations, which I then export and re-import between scores to keep things consistent. When I came back to this score after working on others for a couple months, one of the first things I did was to import my newest custom House Style, and that’s when the playback volume issue began.

Luckily, I’m gung-ho about backups, so I was able to pull a version of my score from a few minutes before I imported the screwy House Style, so though I’ve lost maybe an hour’s worth of work on the score, now it works. Fair compromise, I think.

That said, if anyone can comment with any ideas on whether it’s possible to reverse changes made by an imported House Style (particularly changes to the score’s Playback Dictionary), that would be useful in case the issue ever happened again on a future score.

My thanks to everyone who commented and replied.

  • That's interesting. One of the first things I tried was importing one of the standard House Styles. Playback was still broken. And I looked at the Playback Dictionary definitions of the dynamics and hairpins you used, they appeared normal. – Laurence Payne Sep 9 '17 at 23:51
  • The Playback Dictionary modifications I made were to add pseudo-ghost notes (“g” and “gg”) so that bracketed noteheads actually sound quieter, and a few custom dynamics (pppp, più pp, m, più ff, etc.). I don’t recall whether I changed anything else. Either way, I don’t understand how this could have messed with the playback. What we’d need is a way to completely reset a score’s House Style, nixing anything new or changed from the default style, including in the Playback Dictionary, but I have no idea how to do that, or if it’s possible. – Walter Sep 10 '17 at 0:32
  • You do that by Importing one of the stock House Styles, with all options selected including Playback Directory. But doing this didn't seem to cure the problem with your score. – Laurence Payne Sep 10 '17 at 11:29
  • I can confirm that importing a default House Style does not eliminate any new Playback Dictionary entries you may have added. I just tested it in my score: I imported the “Standard Opus (Times)” style with all options selected, and when I opened the Playback Dictionary my custom entries were still present: “g”, “gg”, “più ff”, “più pp”, etc. So if anything in there got corrupted in the buggy score, it wouldn’t be cleared out just by importing a default House Style. – Walter Sep 10 '17 at 18:10
  • You can delete every entry in Staff Text and System Text, the two places where you can create new entries as well as modify stock ones, leaving those categories empty. Then Import a standard style. This should reset everything. But doing it doesn't solve your problem... – Laurence Payne Sep 10 '17 at 23:11
0

If there's an answer to this, it will be found at the main Sibelius support forum.

http://www.sibelius.com/cgi-bin/helpcenter/chat/chat.pl?groupid=3

Do you want me to post your example score there? Or will you join and do it yourself?

  • Thank you for the kind offer, but it is no longer necessary. I’ve finally identified the problem – a messed-up House Style – and I’ve worked around it by fetching a good backup copy of my score from before I imported the screwy House Style. – Walter Sep 9 '17 at 22:33
0

Have you tried checking the setting of the "Espressivo" feature? (Play -> Interpretation -> Performance)

Depending on how far fetched the variations you mention actually are, the described behaviour could be due to a setting of Espressivo or even Molto Espressivo in a complex multipart score with many expression marks.

If that's the case try setting Performance to "Meccanico".

  • Thanks for the reply. I always set my scores to “Meccanico” on everything, since I like to be in total control of dynamics and volume. And it doesn’t sound like an Espressivo issue, since that affects certain beats and this glitch affects entire measures. – Walter Sep 9 '17 at 19:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.