I recently upgraded my 2018 MacBook Pro to MacOS Mojave and I started getting an error every time I launch Logic Pro X:

Error Initializing CoreMIDI

It's not just a spurious message, because MIDI I/O doesn't work. I can use internal software instruments and sequenced or already recorded MIDI events, but I can't record new MIDI or play any virtual instruments.

Possibly related: Logic also takes about 30 seconds to launch, which is unusually long considering the specs of the computer.

7 Answers 7


This is a known issue in Mojave. There's something wrong with CoreMIDI that causes it to take much longer to initialize than it used to. Logic Pro X has a hard-coded CoreMIDI initialization timeout that expires before CoreMIDI finishes starting, so Logic on High Sierra takes a long time to launch (waiting for CoreMIDI), and then can't use MIDI because the timeout expires.

A good workaround is to initialize CoreMIDI before launching Logic. An easy way to do this is to launch the Audio MIDI Setup utility and open the MIDI Studio window. It will take an unusually long time to load the MIDI studio, but after it has loaded, CoreMIDI will be initialized. Leave that open and launch Logic and it will open up much faster and MIDI will work.

Any other app that initializes CoreMIDI will work also. Advantages of using the Audio MIDI Setup utility is that every Mac has it and it is fairly lightweight, so you leave maximum processing power available for Logic.

Edit: Updating to Catalina also fixes the problem.

  • Interesting, though not one that I found [I'm a Cubase user not Logic]... but it's yet one more reason to get off the disasters that were the Sierras & onto Mojave, which, while not perfect, is a whole lot better than the last two :\
    – Tetsujin
    Commented Jan 30, 2019 at 19:26
  • 1
    @Tetsujin As far as I can tell, this only affects Logic Pro X. Not sure why other software works fine. I use a few other DAWs and scoring software that is MIDI capable and have no problems with anything else. It did take me several days to figure this out, despite a lot of web searches, so I thought I would document it in what IMHO is the best place on the Internet for it. I will say that the processor temp/fan speed system on the later MacOS versions seems bad. I have installed a third-party fan management app because without it the fan never seems to run fast enough and it's very hot. Commented Jan 30, 2019 at 19:27
  • @Tetsujin Oh wait. Maybe I have Mojave. I thought I had the latest, I just can't keep track of what the latest is! Commented Jan 30, 2019 at 19:31
  • 10.14.3 is latest, as of this week. I'm currently on 10.14.4 b1
    – Tetsujin
    Commented Jan 30, 2019 at 19:31
  • 2
    @Tetsujin Sadly, it is Mojave that actually started the problem. CoreMIDI was working fine on High Sierra. I thought Mojave would fix the fan issue, but it didn't. So overall a step backwards for me, but hopefully a Mojave update will fix everything. Not holding my breath, just keeping Audio MIDI Setup open. I am on 10.14.2, so maybe 10.14.4 will fix it, but I have to finish a project I'm working on right now before I'm comfortable updating. Commented Jan 30, 2019 at 19:38

This issue just popped up for me as well- same symptoms (CoreMIDI error when launching Logic Pro X). I had recently updated to Logic 10.4.4, but the big difference is this- I'm still on High Sierra. I'm using an iMac Pro 2017, and Logic had been opening slower than it does on my 2012 Mac Mini. That issue was annoying, but the error was a showstopper.

Keeping the MIDI Setup running in the background did the trick, "fixing" the slow app launch and error messages.


Here's what works for me:

  1. Set the default startup action in Logic to 'Do nothing'.
  2. Start Logic.
  3. If the Coremidi error message occurs, quit and restart Logic instantly.
  4. Voilá, no error this time.

my setup is: Mac Mini 2018, osx 10.14.5 (Mojave)

Intrestingly, this error never came up for a month since i started using Logic. At one point, my 2 year old daughter turned the power off. After this (maybe just coincidence) i started receiving this error, but not always... Maybe I should try resetting some VRAM or PRAM.

  • I just wanted to send an update. I'm not having this issue anymore. Probably the last Mojave update (10.14.5 (18F132)) helped but I'm not 100% sure. Commented Jul 3, 2019 at 10:28
  • Yes, the problem has been fixed. I believe it was Catalina that fixed it for me. Commented Feb 29, 2020 at 8:07

Open Logic Pro X

  1. Preferences
  2. Midi
  3. Reset All Midi Drivers

Close and Reopen Logic Pro X to Check


I found that the error went away after by starting Logic without any midi controllers connected. Connecting them after start up also had no issues. Very weird.


After tried everything, I downloaded "KORG USB-MIDI Driver Uninstaller" from the KORG website and uninstalled the driver: that fixed the issue for me.


I had this problem until, I re read some replies elsewhere on Logic Help etc and I rechecked for KORG stuff on the HD. I moved what I found to a folder on my Desktop. Trying to dump to the trash I got a message saying a file was running although I had disconnected the hardware. Loaded up Clean My Mac and uninstalled the lot. Lo and behold core midi back and no problems thus far.

*****iMac 2.9Ghz, 16GB RAM LOGIC PRO 10.4.6 running Mojave*****

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.