My mfx is zoom g1xon... I just wonder how to bypass preamp and use my built in amp simulation..

It only has input and output. If i send it directly to d input it sounds terrible.

  • 1
    See if you can disable the speaker simulation on your effects unit. Usually the speaker simulation sound that is sent through a real speaker sounds very bad. – Todd Wilcox Mar 14 at 15:15

The G1Xon is designed to go between guitar and amplifier. In what way does it sound terrible? Try setting each effect in the patch to Off. Does it now sound as if it isn't there at all (it should!). Maybe you're just trying to make it add too many effects, or ones you didn't really want. It CAN be a 'multi' effect. It doesn't HAVE to be!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.