2

I started using Musescore 3 about a week ago, and I was successfully able to use a MIDI cable from my electric piano to my computer until today. And yes, I turned on my keyboard, then plugged in the MIDI cord to my computer, THEN opened Musescore.

My set-up:
Musescore v. 3.0.5.5992
Cable: LiDiVi Professional Piano Keyboard to PC/Laptop/Mac MIDI Adapter Cord
Piano: Yamaha P-140
OS: Windows 10

What I've tried:
Restarting Musescore
Restarting my computer
Resetting Musescore to factory settings
Uninstalling and reinstalling Musescore
All the USB ports on my computer

What does work:
The piano works fine on its own
My computer recognizes that a MIDI device is present
NoteInput mode in Musescore does accept inputs from the letter keys

But playing the piano doesn't make any sound through my computer and doesn't update the score when NoteInput mode is on. My Musescore preferences I/O tab has PortAudio checked; there are no options to select for either MIDI input or MIDI output.

Any suggestions? All of the similar problems I've found online seemed to be fixed by a new version of Musescore, but I have the latest version, and I'm pretty sure I haven't changed anything between the last time I successfully used my piano and today.

2

I'm not sure how this worked, but ...

  1. I had someone else install Musescore on their computer and plug in to my piano; it worked
  2. After digging through the drivers associated with MIDI on both our computers, we discovered that the "USB Composite Device" had two drivers associated with it on their computer, whereas mine only had one
  3. We copied the one that was only on their computer to the equivalent folder on my computer
  4. Restarted my computer
  5. MIDI input works again (even though the copied driver still isn't showing up for the USB Composite Device)

EDIT:
It's also possible that it started working again because I had my MIDI cable plugged into my computer when I restarted it; when I tried to start playing on Musescore again today, it had stopped working again (I'm assuming because I had unplugged then replugged in my cable since yesterday). So I restarted my computer while the cable was still in and it started working again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.