0

The height of music waveforms exported from LMMS are very high and I'm afraid it might lead to clipping or unbalanced volume when accompanied with video. The track in LMMS which is a 1-min loop was created using the a Bass preset (Bass 2) from ZynAddSubFX presets, along with a kick and a hihat. The only FX addon I applied on it is Calf Compressor LADSPA. On the other hand, the waveforms of the audio recorded with Mac microphone is half way tall. The difference between waveforms is clearly visible in my video editor. Here's screenshots of both:

Music exported from LMMS:

enter image description here

Audio recorded by Mac:

enter image description here

I might be able to lower the waveforms, but I am looking for a way to do that in LMMS. So, in short, why does this happen and how can I prevent it?

By the way, the exported track does not sound much peaky and sounds OK, but why do the waveforms say otherwise?

Take a listen to the track:

https://vocaroo.com/i/s0xlaW5jHjNT

  • @leftaroundabout please see the updated post. – codezombie Jul 24 at 12:50
3

Without having listened to your track: it's not surprising at all it looks this way if this is just a bass-and-drums loop with not changes. How could it look anything but constant-peaks-amplitude, if it is a loop that literally repeats in exactly the same way?

The fact that this constant amplitude is actually 0 dB (i.e. the maximum possible) is just a matter of normalisation. It's standard practice to set the level as high as possible without clipping when exporting audio. Either the compressor plugin is set to normalise the output, or LMMS does that in the bouncing/exporting action.

Even if it wasn't a loop: a compressor has essentially the purpose to bring any audio closer to constant level. This is very often a desired thing, in particular for something like a video soundtrack: if there's lots of dynamic fluctuation, it's much harder to mix it together without the peaks disrupting the voice-over or else the music getting feeble in the background. Of course you will need to properly adjust the mix levels for the video cut, but that needs to be done either way. Your loud music track will probably need to have quite a low mix setting in the video, but that's not a pad thing per se.

Also in music production, especially pop, mastering engineers will often apply so much compression that the peak level across the track is almost constant 0 dB. This way the overall track will sound as loud as physically possible even on small speakers. The downside is that the music isn't as dynamic anymore. This has been a big debate termed the loudness war. But that doesn't really apply for you if you really have just a loop: there are no dynamics in the first place, so also no issue removing them with a compressor!

Bottom line: don't worry about this. You could certainly reduce the output level in LMMS, but if the track doesn't actually sound bad to you then there's no real reason. You should make sure you've actually checked it on studio monitors as well as headphones, to make sure it isn't also clipped after all.

0

the exported track does not sound much peaky and sounds OK, but why do the waveforms say otherwise?

Each software can render waveforms differently, so I don't think judging audio level by inspection of the waveform is an accurate idea.

For example, in Reaper you can alter the size of the waveform. You can make it look as big or small as you want. Of course, all the levels are relative and are shown ok, but depending on your editing needs you might want them displayed bigger or smaller.

Measure your waveforms, watch the vumeter. Don't stay just with the inspection of the waveform.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.