2

Setup: M-Audio Keystation 49 -USB-> Windows 10 PC running Ableton Live hosting the AddictiveKeys VSTi. I've already stripped other stuff out of the equation to make things simpler.

[See updates below -- various tests that establish the problem is internal to Live, not a hardware issue.]

This has been working for several months with no issues (in fact, as part of a much more complicated setup), but I had to disassemble my studio last week and reassemble it a few days later and now I have a weird problem. In the intervening time the PC has been unplugged and since turning it back on I haven't updated any software (including Windows).

Here is what happens:

  1. Fire up Ableton. Everything is fine. Can play AddictiveKeys with the keyboard.

  2. 5-10 seconds later, the last note(s) played on the keyboard sustain forever and further key presses result in no response from AddictiveKeys.

  3. I go to Options -> Preferences -> Link MIDI and turn off the Track Input for the keyboard, then turn it back on again. Everything starts to work fine again for 5-10 seconds and the cycle repeats.

The "MIDI Track In Indicator" in the top right corner of the screen continues to flash when notes are pressed, which I think confirms that the keyboard is working correctly. But the Max4Live MIDI monitor on the track shows no new notes coming in, as does the little MIDI monitor on the track itself.

Furthermore, MIDI-Ox shows the keyboard sending MIDI fine and doesn't cut out or do anything else unexpected.

I think this must mean that some internal routing within Ableton is malfunctioning, but I can't see how to diagnose this any further.

What I've tried that didn't help:

  1. Swapping USB cables and ports
  2. Removing all unnecessary USB devices
  3. Swapping AddictiveKeys with another VSTi
  4. Turning off and on again (PC and Ableton itself)
  5. Looking at Ableton's website for customer support options (I'm on a Lite license I got free with a piece of gear so I'm out of luck).
  6. Googling. I see a couple of people reporting a similar issue on other forums but with different setups and no suggestions for how to fix it.
  7. Setting the MIDI track in Ableton to listen only on the channel that the keyboard sends on (not All Channels).
  8. Tested my external devices are working in MIDI-OX and LMMS (everything works fine in both, no sign of any weirdness).

If anyone has any ideas what to try next I'd be much obliged -- I'm relatively new to Ableton Live.

UPDATE: I rebooted the PC with no USB devices attached except the audio interface, keyboard and mouse. Created a new Live set with only one channel for AddictiveKeys, with MIDI input coming from the computer keyboard. Turned on the keyboard button in the top right and it plays fine -- for 5-10 seconds. Then freezes again in exactly the same way. So the issue is certainly internal to Ableton, not with any external device.

As an aside, I also tested that all my USB ports are powered, which they are (tested by plugging in a USB-powered LED lamp). It's quite possible that since tearing down & setting back up, devices got plugged into different ports but I've tried enough combinations now to be pretty sure that's not the issue.

UPDATE 2: Further tinkering has revealed more problems with Ableton between its tracks' MIDI commands and what goes in and out. If I plug in an external hardware synth and write a simple MIDI track in Ableton, it shows the MIDI note on/off messages being generated on the correct channel (the MIDI note indicator jumps at the appropriate moments), but no MIDI data is arriving at the other end. Again, this was working perfectly before and MIDI-OX can send notes to the external synth no problem at all.

UPDATE 3: I tried deleting both Ableton folders in my user directory; this appeared to restore Live to "factory settings", forgetting all my preferences and my activation code. But the problem was still present. I guess it's time to give up on Live and move to a different product.

  • when the last note gets stuck on, that normally means the MIDI Note Off message was missed somehow. What happens when you use one of Ableton's internal MIDI instruments? – danmcb Nov 6 at 18:16
  • look for a setting in the Ableton MIDI menu that always sends NOTE OFF at end of a clip, although that doesn't exactly match your issue it sounds related. – danmcb Nov 6 at 18:22
  • Good thoughts. I just tried with Electric and got exactly the same behaviour. There does seem to be an issue with the last note getting stuck but since these are polyphonic instruments I don't think that can be the whole problem... – helveticat Nov 6 at 18:50
  • I would just delete every control surface in Ableton, and then start from scratch. It sounds like something is muddled up somewhere. Odd problem though. – danmcb Nov 6 at 20:54
  • I think I tried that, in the sense that if you unplug everything and start Live it doesn't see any control surfaces, they're not present in the Preferences window anyway... then as you plug them in it sees them again. Maybe there's a way to "reset to factory settings" as it were without a complete reinstall (which is my next try, I think). – helveticat Nov 6 at 21:06
2

To satisfy my curiosity, I uninstalled and reinstalled Live this morning. Everything was working fine after that. So in case someone in the future encounters this problem and despite that wants to persist with Ableton, that's the only thing that worked for me.

Thanks to @danmcb and @piiperi for helping me through the debugging process.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.