Spoiler: At least for my issue I found a solution, see my answer for that.

Recently I got back into recording and wanted to connect my Focusrite Liquid Saffire 56 to my Windows 10 machine. AFAIK the liquid and the pro editions are all connected via firewire so I also bought a PCI Express firewire card for my machine.

I grabbed the latest Saffire MixControl which is 3.7 for windows but at the end I kept the older 3.4 version, which should not matter for the issue.

My machine kept detecting the saffire and my DAW and OS told me that it is there but I was not able to record with it and got always generic errors during opening the audio device. Furthermore the saffire mix control kept saying "no hardware connected"

I checked the firewire cable and socket, albeit a bit wobbly they are ok since the PC detects the interface properly.

6 Answers 6


Bad news first:

Focusrite discontinued the support for the Saffire 56 from Windows 10 build 1903 due to device incompatibilities in the firewire interface and says "it will not work on versions >= 1903". That's not a good start for that.

Good news:

Regardless of this fact my audio interface seems to work very stable and reliable on my windows 10 machine now.

My PC had no firewire inputs on the board so I bought a delock PCI firewire card. The brand is not important, important was the fact that Focusrite supports only VIA and Texas Instruments chipsets on the firewire interface. I was lucky because I had the Texas Instruments chipset and also the card was rated for 400 mbps, just like my saffire needed.

Beside that I could not work with the Saffire Mix Control nor record anything. The device appeared to be there but only as a non working zombie. I knew from the past that the interface was working on Windows 7 and cannot remember whether it did on 10.

After testing all of those focusrite articles and some threads on various forums I found an issue with microsofts driver selection in the device manager for my firewire card.

Looking at the device manager for the firewire card I noticed something strange:

device manager

Seems to work and looking good but then I said "wait, wasn't my firewire chipset's brand Texas Instruments and not VIA?"

Windows insisted it was a generic VIA chipset so I right clicked onto it, went to settings/properties, picked the "driver" tab, selected "Update driver" then selected the "locate driver on my machine", then clicked "pick one from a list" and got basically two different options:

  • OHCI compliant VIA 1394 Host Controller
  • OHCI compliant 1394 Host Controller

I selected the non VIA version, installed it and that fixed my problem. The Saffire Mix Control was then able to detect the saffire without any issues and I was able to record instantly.

Firewire is quite old and I guess since windows already provides the drivers for firewire, the PCI card manufacturer relied on windows for matching it's chipset signature to the necessary driver. Either the PCI card manufacturer or microsoft botched things up picking a driver that only "seemed" to work.

If you have the same issue I hope it will help my fellow friends in the firewire hell :)

Small disclaimer: The process of selecting another driver might use a different wording, I recommend searching for a guide on how to do this if you are stuck or not sure. My windows machine uses a non English language so the guide above might be not entirely accurate on the wording you might find on your machine.


I was having same problem on windows 10 1903 (using TI chipset pcie card with laptop. I was getting cycling through sample rates and defaulting to 192k.

I found that by installing 2006 dated driver (probably from windows 7) that it became stable again and my Liquid Saffire 56 is working well with 2 octopre mkii.

I haven't dared yet to upgrade to version 1909 and have switched off feature updates on windows 10.


I now have have Saffire Liquid 56 running on windows 10 1909 and 2004.

It is important still to have the legacy driver installed but the sampling rate cycling still occurs.

I found that if you set the liquid 56 as default device in sound control panel for both speakers and microphone and ensure on the advanced tabs for each that the default sampling rate e.g. 24bit 48k is set to the same for both speakers and microphone it stabilizes.

It seems that windows selects the default highest rate e.g. 192k and causes the cycling. By setting a default sample rate locks ok. You can subsequently change the sample rate in saffire mix control and it remains solid

N.B. I'm using saffire mix control version 3.7 and a TI firewire pci Express card which fits into a PCI express card slot on my laptop. The card driver verifies using the Focusrite OHCI tool .


I'm currently experimenting with the instructions found here.

By selecting the legacy driver, I can now use settings in the saffire mixcontrol that the Texas Instrument driver from my previous installations (which worked fine before Windows 10 2009, and have stopped working since the current windows 10 version).

How do I install the Firewire 1394 Legacy Driver in Windows 10?

  1. Download the Microsoft Firewire 1394 Legacy Driver Installer
  2. Double-click to run the 1394_OHCI_LegacyDriver.msi file. This will extract the drivers to: C:\Program Files (x86)\1394 OHCI Compliant Host Controller (Legacy)\
  3. Open the folder: C:\Program Files (x86)\1394 OHCI Compliant Host Controller (Legacy)\X64_driver\
  4. Right-click on Legacy1394.inf and choose Install to install the drivers
  5. Press the Windows Key + R
  6. Type devmgmt.msc
  7. Click OK
  8. In Device Manager, expand IEEE 1394 Bus Host Controllers
  9. Right-click on 1394 OHCI Compliant Host Controller
  10. Click Update Driver Software
  11. Click Browse my computer for driver software
  12. Click Let me pick from a list of device drivers on my computer
  13. Click 1394 OHCI Compliant Host Controller (Legacy)
  14. Click Next
  15. (When Windows has finished installing the driver) click Close

My focusrite safire pro 40 worked fine under windows 10 with a startech firewire card. But after some windows update it stopped working.

I Tried updating the safire mix control - all of them, 3.4, 3.7, back to 2.4. none work.
I followed the instructions at https://www.startech.com/en-us/faq/firewire-cards-windows-legacy-driver-swap to restore the old driver that actually worked.
After the step 12. Click Let me pick from a list of device drivers on my computer and step 13. Click 1394 OHCI Compliant Host Controller (Legacy), Windows paternally and incorrectly informs me "The best drivers for your device are already installed". However, if they were the best drivers my interface would work again, wouldn't it? I am about ready to hang it up & buy a USB interface ENTIRELY All because MS changed the software WITHOUT giving me a choice. And now won't give me a choice over which driver I want to use.

I was not choosing the next step correctly, this part is VERY important :

Click **Let me pick from a list** of device drivers on my computer
enter preformatted text here
Click 1394 OHCI Compliant Host Controller (Legacy)
enter preformatted text here

I chose the 1394 OHCI Compliant Host Controller (Legacy) and my beloved PRo 40 started working again. Definitely try these instructions and follow each step exactly, in ORDER...


Have the same issue here, I upgraded to windows 10 build 1909 and having issues with Saffire pro 40 interface. I downloaded mix control 3.7 and it worked fine for a while. Going to download legacy drivers and hope it resolved my case. I'm using a Texas card as well.

  • 1
    Welcome to Music: Practice & Theory! If you have a NEW question, please ask it by clicking the Ask Question button. If you have sufficient reputation, you may upvote the question. Alternatively, "star" it as a favorite and you will be notified of any new answers. If your approach works, that's the moment to post it as an answer.
    – Glorfindel
    Apr 21, 2020 at 17:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.