1

I have a Behringer X-Touch Compact hooked up to provide basic transport and level/pan controls to Logic Pro X (currently 10.4.8).

At some point recently (since I last worked on a track about a month ago) I'm finding that, regardless of which project I have opened, the fader banks now seem to be assigned per channel number (an abstract concept I'd never been aware of!) rather than track number. This basically makes it impossible to use, as I'll create tracks and then move them around into logical groups, but now the are non-contiguous, so navigating the banks is completely impractical:

In the screenshot, the drums are on track 12, playing through audio 4, so rather than my current fader bank being a group of adjacent tracks, it's now got a hole in the middle (track 11) since track 10 is audio 1, track 11 is audio 10. It's even worse for some of my other tracks where I've moved things around more.

I am certain this isn't the behaviour I used to have, but I have no idea what's changed - I can't find any relevant setting in the control surface settings.

The problem doesn't appear on my laptop running 10.5 (which I barely use) but I'm wary of upgrading my main machine to 10.5 in the middle of working on a project, so I'd like to get a sense of the root cause before trying that, if possible.

enter image description here

2
  • Breaking controls into channels sounds like it could be trying to do MPE, which is a workaround in MIDI where you send channel-wide messages (like pitch and aftertouch) on separate channels so you can have separate messages for each note. Try to see if the controller or Logic has an MPE function somewhere and turn it off. May 23 '20 at 12:40
  • @ToddWilcox thanks, though I don't think this is relevant - the channels being discussed here are Logic's audio channels (all the tracks in question are audio channels, not midi ones). All the midi data in this setup is coming through a single midi channel from the controller.
    – dom
    May 23 '20 at 12:50
2

Finally figured this out. The setting in question is "Channel Strip View Mode" in Control Surfaces -> "Setup". It was set to "all" which caused it to assign strips to channels. Changing it to "Tracks" restored the behaviour I was expecting.

Channel Strip View Mode setting

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.