0

I have a Kurzweil Re-210 digital piano that has no sound and the display shows---. I have tried the MiDi/Pref button and nothing happens and have contacted multiple repair people and no one has an answer.

  • Have you tried output from Headphone Output or Audio Out Jack – david strachan Jul 4 '16 at 6:30
  • If "nothing works" but the keyboard is obviously powered up (because the display shows something), the most likely reason is that some electronic component has failed. Repair techs aren't going to get excited about trying to fix a discontinued product like the Re-210, because the quickest way to diagnose faults is simply by swapping circuit boards and modules till it comes back to life. They probably won't have a stack of old Re-210 parts in the store room, and ordering a set of spares just for you will cost more time and money that you are likely to want to pay them to fix it. – user19146 Jul 4 '16 at 19:41
3

According to the owner's manual, the instruments resets settings on powerup so it should be playable regardless of what was set under MIDI/pref.

That the display shows nothing but (- - -) indicates that the problem most likely isn't in audio output (DAC, amplifier, speakers...), but an internal problem.

The service manual seems to be easily found by google. Here's the top result:
http://www.kevinchant.com/uploads/7/1/0/8/7108231/re-210_service_manual.pdf

There you'll find simple instructions for the diagnostics test. Diagnostics mode is entered by pressing "DEMO" and "MIDI/Pref" buttons simultaneously after power up.

If that doesn't do anything, you'll probably need to open the chassis and check that all cables are intact and connected, and whether there's physical damage to the circuit boards.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.