3

I'm using macbook pro, logic pro x as DAW and kawai VPC1 as a midi keyboard (no external sound card).

When there are a lot of sounds stacked on top of each other, some of them start disappearing. Check out this file for reference: pedal is always pressed, and you can clearly hear the bottom chord disappearing after a while). Is it a problem of internal sound card?

  • What pedal are you talking about? – Todd Wilcox May 8 at 19:51
  • The usual one, sustain pedal. I'm using Kawai F-30 – Claud H May 8 at 19:53
  • 2
    What sound source is actually making the piano sound? – topo Reinstate Monica May 8 at 20:52
  • 1
    @topomorto Sorry for delay, went to sleep. Ravenscroft 275 – Claud H May 9 at 7:41
6

Hardware instruments (e.g. digital pianos) have a limit on the number of simultaneous notes that they can produce - this part of their spec is called "polyphony". As Todd explained, once you exceed the limit, notes start getting cut off. Some instruments try to do this in a clever way, cutting off the least noticeable notes; others are a bit more basic, just cutting off the earliest note played. This can sound very obvious!

Software instruments shouldn't need to have any particular hard limit on polyphony, as they should be able to produce as many notes simultaneously as the host computer can handle. However, they might provide a way to limit polyphony to avoid using too much resource. It seems that the Ravenscroft 275 has these kind of settings:

Ravenscroft 275

I would certainly try experimenting with the Polyphony and Sympathetic Polyphony. Some of the other settings (like pedal noise, pedal resonance, or key noise) might have an effect too. Perhaps my Google skills are weak but I couldn't find any manual where each of these settings is explained in detail - maybe you have one as an actual owner of the S/W, or you might want to contact the manufacturer.

The effect of allowing the instrument too much polyphony will be to increase the potential load on your CPU, which may cause the audio to become glitchy and drop out. You may need to experiment to find the right balance between getting enough polyphony and keeping the audio working smoothly. (It may be that to get a lot of polyphony with this instrument, you need quite a powerful PC).

  • 1
    Makes sense. I put them at max some time ago, but the settings reset for some reason. – Claud H May 9 at 11:01
  • Try a 'reasonable' rather than max number. A lower end digital piano spec will show 64 polyphony. A higher end model will show 192. Perhaps the 'max' setting cannot save due to a software issue (overflow of some sort). – Paul May 10 at 14:53
6

You're probably running out of voices of polyphony. You haven't clarified what virtual instrument or synthesizer is the sound source, but most of them have some sort of voice limit, ranging from 1 to 128 voices. If you keep the damper pedal down, then voices can get used up very quickly.

For most instruments, when the voices are used up and another note is played, it will stop playing the earliest played note and use that voice for the note that was just played. Since you are playing the lowest notes first, then that would explain why they are the first to go away.

  • Yeah, my bad. I was using Ravenscrofts 275 VST – Claud H May 9 at 7:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.